This forum is now just an archive. Use the new Q&A website
It is currently Thu Apr 24, 2014 6:10 pm

All times are UTC + 2 hours




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 51 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject: Re: New modules in Data Migration module group
PostPosted: Tue Jul 26, 2011 6:38 pm 
Offline

Joined: Tue Mar 10, 2009 1:04 pm
Posts: 11
Thanks for the information but i still persist with the error connecting with old server from GTK client or web client :(


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Tue Jul 26, 2011 10:05 pm 
Offline

Joined: Sun Dec 28, 2008 1:03 pm
Posts: 200
Location: Genoa
Get last changes with
bzr pull lp:~domsense/domsense-agilebg-addons/datamig-6
and you should see a more significant error message

_________________
Lorenzo Battistini
http://planet.domsense.com/en/author/elbati/
http://www.agilebg.com/


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Wed Jul 27, 2011 7:56 am 
Offline

Joined: Tue Mar 10, 2009 1:04 pm
Posts: 11
I updated the code and i get this error from client v6 side

Code:
[Errno 104] Conexión reinicializada por la máquina remota


Then i go to server v5 log and i see this

Code:
Exception happened during processing of request from ('200.1.0.5', 41419)
Traceback (most recent call last):
  File "/usr/lib/python2.6/SocketServer.py", line 560, in process_request_thread
    self.finish_request(request, client_address)
  File "/usr/lib/python2.6/SocketServer.py", line 322, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/usr/lib/python2.6/SocketServer.py", line 617, in __init__
    self.handle()
  File "/usr/lib/python2.6/BaseHTTPServer.py", line 329, in handle
    self.handle_one_request()
  File "/usr/lib/python2.6/BaseHTTPServer.py", line 312, in handle_one_request
    self.raw_requestline = self.rfile.readline()
  File "/usr/lib/python2.6/socket.py", line 444, in readline
    data = self._sock.recv(self._rbufsize)
Error: [('SSL routines', 'SSL23_GET_CLIENT_HELLO', 'http request')]


I'm working with port 8070 IRC this port works without SSL , isn't ?


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Wed Jul 27, 2011 8:51 am 
Offline

Joined: Sun Dec 28, 2008 1:03 pm
Posts: 200
Location: Genoa
javivf wrote:
I'm working with port 8070 IRC this port works without SSL , isn't ?

It depends on your configuration...
BTW, you have to use XML-RPC, listening on port 8069 by default

_________________
Lorenzo Battistini
http://planet.domsense.com/en/author/elbati/
http://www.agilebg.com/


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Wed Jul 27, 2011 11:09 am 
Offline

Joined: Tue Mar 10, 2009 1:04 pm
Posts: 11
eLBati wrote:
BTW, you have to use XML-RPC, listening on port 8069 by default


I setup "Secure = False" on server and i try to connect XML-RPC and it works!
Your effort is very appreciated, thanks.


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Wed Aug 31, 2011 1:28 pm 
Offline

Joined: Wed Aug 31, 2011 1:25 pm
Posts: 2
Location: Spain
Also you can change in all .py of the migration module the string http -> https if you need a secure xmlrpc connection.


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Wed Aug 31, 2011 1:35 pm 
Offline

Joined: Wed Aug 31, 2011 1:25 pm
Posts: 2
Location: Spain
I'm probing the module, connection to the old server.

But when I do schedule migration, and see the scheduled migration I've the next error:

<<<<<<<<<<<<<<<< Error! >>>>>>>>>>>>>>>> Traceback (most recent call last): File "C:\Archivos de programa\OpenERP 6.0\Server\addons\server_migration\migration.py", line 626, in _import_data File "C:\Archivos de programa\OpenERP 6.0\Server\addons\server_migration\migration.py", line 589, in import_model File "C:\Archivos de programa\OpenERP 6.0\Server\addons\server_migration\migration.py", line 329, in create File "osv\fields.pyo", line 644, in set File "sql_db.pyo", line 78, in wrapper File "sql_db.pyo", line 131, in execute IntegrityError: duplicate key value violates unique constraint "res_partner_category_rel_partner_id_key"


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Wed Aug 31, 2011 4:16 pm 
Offline

Joined: Sun Dec 28, 2008 1:03 pm
Posts: 200
Location: Genoa
https://bugs.launchpad.net/domsense-agi ... comments/1

_________________
Lorenzo Battistini
http://planet.domsense.com/en/author/elbati/
http://www.agilebg.com/


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Fri Nov 25, 2011 11:00 pm 
Offline

Joined: Sat Apr 25, 2009 1:08 am
Posts: 39
Hi eLbati,

I can´t install "server_migration module" over 6.03 version, this error appers :

Apply Scheduled Upgrades Help
Su sistema será actualizado
Para su informciín, esta operación puede llevar varios minutos
Módulos a actualizar
server_migration : to install

Advertencia
Error occurred while validating the field(s) parent_id: Error ! You can not create recursive Menu.
OK

Could be that a minimal o clean Database is required?
Thanks
Luis


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Sat Nov 26, 2011 10:55 am 
Offline

Joined: Sun Dec 28, 2008 1:03 pm
Posts: 200
Location: Genoa
ltobar wrote:
Advertencia
Error occurred while validating the field(s) parent_id: Error ! You can not create recursive Menu.

You probably downloaded a wrong version of the module.
Refer to https://code.launchpad.net/~domsense/do ... /datamig-6

_________________
Lorenzo Battistini
http://planet.domsense.com/en/author/elbati/
http://www.agilebg.com/


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Mon Nov 28, 2011 10:50 pm 
Offline

Joined: Sat Apr 25, 2009 1:08 am
Posts: 39
Hi,

I download all the datamining-6 modules again.
ltobar wrote:
Hi eLbati,

I can´t install "server_migration module" over 6.03 version, this error appers :

Apply Scheduled Upgrades Help
Su sistema será actualizado
Para su informciín, esta operación puede llevar varios minutos
Módulos a actualizar
server_migration : to install

Advertencia
Error occurred while validating the field(s) parent_id: Error ! You can not create recursive Menu.
OK

Could be that a minimal o clean Database is required?
Thanks
Luis
we are using openerp 6.0.3..
but fail again at the install moment, the error is :

Error occurred while validating the field(s) res_model, src_model: Invalid model name in the action definition.


Thanks a lot
Luis


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Tue Nov 29, 2011 9:53 am 
Offline

Joined: Sun Dec 28, 2008 1:03 pm
Posts: 200
Location: Genoa
openobject-server/6.0 revno 3545
openobject-addons/6.0 revno 4936
~domsense/domsense-agilebg-addons/datamig-6 revno 9

just installed server_migration without problems

_________________
Lorenzo Battistini
http://planet.domsense.com/en/author/elbati/
http://www.agilebg.com/


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Sat Jan 14, 2012 1:54 pm 
Offline

Joined: Sun Dec 28, 2008 1:03 pm
Posts: 200
Location: Genoa
I changed the owner of the branch so that everyone can contribute:
https://code.launchpad.net/~openerp-com ... /datamig-6

_________________
Lorenzo Battistini
http://planet.domsense.com/en/author/elbati/
http://www.agilebg.com/


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Sun Jan 15, 2012 11:54 pm 
Offline

Joined: Sun Dec 28, 2008 1:03 pm
Posts: 200
Location: Genoa
Hello,
I started porting server_migration to 6.1.
Here is the branch:
https://code.launchpad.net/~openerp-com ... ration-6.1
If someone wants to test, it works out now

_________________
Lorenzo Battistini
http://planet.domsense.com/en/author/elbati/
http://www.agilebg.com/


Top
 Profile  
 
 Post subject: Re: New modules in Data Migration module group
PostPosted: Sat Jan 21, 2012 9:12 am 
Offline

Joined: Thu Aug 05, 2010 7:47 am
Posts: 6
hey lorenzo

yesterday (0130 am) i successfully installed oerp 6.1 ... tested around and... wow amazimg..
then i saw your server_migratin 6.1... installed, but can't configure server connections...
if i click on load configuration, i have just a cancel and load button.

for migrating my data from 6.0.3 do i need datamig6 or server_migration 6.1?

thsnks for help

thomi


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 51 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC + 2 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:

Protected by Anti-Spam ACP