This forum is now just an archive. Use the new Q&A website
It is currently Thu Apr 17, 2014 1:00 am

All times are UTC + 2 hours




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 10 posts ] 
Author Message
 Post subject: OpenERP 6.1 for OpenSuse 12.1 (RPM package)
PostPosted: Mon Mar 26, 2012 7:50 am 
Offline

Joined: Fri Feb 03, 2012 5:48 am
Posts: 7
Location: Canada
I am using OpenERP 6.0.3 on OpenSuse 12.1, like to upgrade to 6.1.1, where can I get the RPM package(s) for OpenSuse 12.1 ?

Thanks.


Top
 Profile  
 
 Post subject: Re: OpenERP 6.1 for OpenSuse 12.1 (RPM package)
PostPosted: Mon Mar 26, 2012 9:27 am 
Offline

Joined: Wed Jan 18, 2012 12:57 pm
Posts: 322
Location: cochin
http://www.openerp.com/downloads

_________________
Regards,
Nightfury


Top
 Profile  
 
 Post subject: Re: OpenERP 6.1 for OpenSuse 12.1 (RPM package)
PostPosted: Mon Mar 26, 2012 4:50 pm 
Offline

Joined: Fri Feb 03, 2012 5:48 am
Posts: 7
Location: Canada
nightfury wrote:


I am looking for RPM package.


Top
 Profile  
 
 Post subject: Re: OpenERP 6.1 for OpenSuse 12.1 (RPM package)
PostPosted: Tue Mar 27, 2012 7:11 am 
Offline

Joined: Wed Jan 18, 2012 12:57 pm
Posts: 322
Location: cochin
http://www.openerp.com/node/1024

_________________
Regards,
Nightfury


Top
 Profile  
 
 Post subject: Re: OpenERP 6.1 for OpenSuse 12.1 (RPM package)
PostPosted: Tue Mar 27, 2012 11:14 pm 
Offline

Joined: Fri Feb 03, 2012 5:48 am
Posts: 7
Location: Canada
nightfury wrote:
http://www.openerp.com/node/1024

Thanks for the link. I'll try shortly, let you know the result.


Top
 Profile  
 
 Post subject: Re: OpenERP 6.1 for OpenSuse 12.1 (RPM package)
PostPosted: Tue Apr 03, 2012 5:24 am 
Offline

Joined: Fri Feb 03, 2012 5:48 am
Posts: 7
Location: Canada
The installation was successful but OpenERP doesn't start on OpenSuse 12.1

What I did:
1. Converted the Ubuntu/debian package of OpenERP 6.1 to .rpm package using "alien" tool
2. Installed on OpenSuse 12.1, installation was successful
3. Configured openerp-server.conf file (as suggested in Step-6 of http://www.theopensourcerer.com/2012/02/22/how-to-install-openerp-6-1-on-ubuntu-10-04-lts/
3. Started Postgresql, openerp-server
4. Opened browser pointing to "http://localhost:8069"

The OpenERP 6.1 doesn't start.


Top
 Profile  
 
 Post subject: Re: OpenERP 6.1 for OpenSuse 12.1 (RPM package)
PostPosted: Tue Apr 03, 2012 7:07 am 
Offline

Joined: Wed Jan 18, 2012 12:57 pm
Posts: 322
Location: cochin
try local host 8080 or does it shows any error in the terminal?

_________________
Regards,
Nightfury


Top
 Profile  
 
 Post subject: Re: OpenERP 6.1 for OpenSuse 12.1 (RPM package)
PostPosted: Tue Apr 03, 2012 2:29 pm 
Offline

Joined: Tue Apr 03, 2012 2:24 pm
Posts: 2
Location: Wigan
OpenERP install on openSuse 12.1 WITHOUT alien

Add these additional repositories
spin:invis
http://download.opensuse.org/repositories/spins:/invis/openSUSE_12.1_standard/

devel packages python
http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_12.1/

Needed python packages for openerp 6.1 on openSuse 12.1
python 2.7.2-7.5.1
python-Babel 0.9.6-9.1
python-Beaker 1.6.2-9.1
python-Mako 0.5.0-8.2
python-MarkupSafe 0.15-10.1
python-PyYAML 3.10-3.1
python-base 2.7.2-7.5.1
python-dateutil 1.5-17.1
python-devel 2.7.2-7.5.1
python-distribute 0.6.25-29.1
python-imaging 1.1.7-24.1
python-ldap 2.4.9-15.2
python-lxml 2.3.3-24.1
python-psycopg2 2.4.4-4.1
python-pyasn1 0.1.2-11.1
python-pyasn1-modules 0.0.2-1.1
python-pychart 1.39-14.1
python-pydot 1.0.25-1.1
python-pyparsing 1.5.6-15.1
python-reportlab 2.5-18.1
python-tk 2.7.2-7.5.1
python-tz 2011n-16.1
python 12.1 python-xml 2.7.2-7.5.1

get openerp from here:
http://nightly.openerp.com/6.1/releases/openerp-6.1-1.tar.gz
unpack tarfile,
open console into the unzipped openerp folder
execute typing python setup.py install

hope this helps


Top
 Profile  
 
 Post subject: Re: OpenERP 6.1 for OpenSuse 12.1 (RPM package)
PostPosted: Mon Sep 17, 2012 1:44 pm 
Offline

Joined: Mon Sep 17, 2012 1:18 pm
Posts: 2
Location: Schotten, Germany
Hello,

i am Stefan from invis-server.org. I think that i should mention here, that our RPMs did'nt work yet and that i need help for finalizing them! http://www.openerp.com/forum/topic34463.html

Stefan


Top
 Profile  
 
 Post subject: Re: OpenERP 6.1 for OpenSuse 12.1 (RPM package)
PostPosted: Wed Dec 12, 2012 4:16 pm 
Offline

Joined: Wed Dec 12, 2012 3:57 pm
Posts: 1
Location: Portugal
Dear diba1958,

I try your method. Installed all the necessary packets via "YaST Software Manager", except the last (python 12.1 python-xml 2.7.2-7.5.1) that it couldn't find.

The shell stopped here, in the error transcribed below:

Downloading http://downloads.sourceforge.net/pyxml/ ... g_mirror=0
Processing PyXML-0.8.4.tar.gz
Running PyXML-0.8.4/setup.py -q bdist_egg --dist-dir /tmp/easy_install-wBYUhp/PyXML-0.8.4/egg-dist-tmp-TRwfZ8
warning: no files found matching '*.html' under directory 'extensions/expat'
warning: no files found matching '*Makefile' under directory 'extensions/expat'
warning: no files found matching '*.dsp' under directory 'extensions/expat'
warning: no previously-included files matching '*/CVS/*' found anywhere in distribution
unable to execute gcc: No such file or directory
error: Setup script exited with error: command 'gcc' failed with exit status 1

Then I installed the GNU compiler (gcc) and run again on the shell "python setup.py install" and the process ran until the end, but...

... gave me the same mistake in the middle of it, trasncribed below:

Running PyXML-0.8.4/setup.py -q bdist_egg --dist-dir /tmp/easy_install-N3odnq/PyXML-0.8.4/egg-dist-tmp-9pyMYQ
warning: no files found matching '*.html' under directory 'extensions/expat'
warning: no files found matching '*Makefile' under directory 'extensions/expat'
warning: no files found matching '*.dsp' under directory 'extensions/expat'
warning: no previously-included files matching '*/CVS/*' found anywhere in distribution
extensions/sgmlop.c:718:5: warning: ‘intargfunc’ is deprecated [-Wdeprecated-declarations]
extensions/boolean.c: In function ‘boolean_cmp’:
extensions/boolean.c:121:22: warning: variable ‘b2’ set but not used [-Wunused-but-set-variable]
extensions/boolean.c:120:22: warning: variable ‘b1’ set but not used [-Wunused-but-set-variable]
SyntaxError: ('invalid syntax', ('build/bdist.linux-i686/egg/_xmlplus/xpath/ParsedAbbreviatedAbsoluteLocationPath.py', 27, 10, " as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')\n"))

SyntaxError: ('invalid syntax', ('build/bdist.linux-i686/egg/_xmlplus/xpath/ParsedAbbreviatedRelativeLocationPath.py', 31, 10, " as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')\n"))


Can someone give me a hint, please?

Thank you.


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 10 posts ] 

All times are UTC + 2 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:

Protected by Anti-Spam ACP