This forum is now just an archive. Use the new Q&A website
It is currently Wed Apr 23, 2014 2:12 pm

All times are UTC + 2 hours




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 7 posts ] 
Author Message
 Post subject: openerp 6.1 reverse proxy settings
PostPosted: Sun Mar 04, 2012 5:31 pm 
Offline

Joined: Fri Jan 22, 2010 11:19 pm
Posts: 146
Hi,

I would like to access my openerp 6.1 server via the internet.
I've my INTRANET up running on apache with a trusted ssl-certificate.

I've added these 2 lines to my apache2/sites/-file of my INTRANET (Server1):
Code:
        ProxyPass /openerp http://IP-OF-OPENERP:8069/web/webclient/home
        ProxyPassReverse /openerp http://IP-OF-OPENERP:8069/web/webclient/home


And I've added these lines to my openerp-server.conf:
Code:
tools.proxy.on = True
tools.proxy.base = ‘https://MY.INTRANET.COM:8081’
tools.proxy.local= ''
tools.nestedvars.on=true
tools.csrf.on = False


If I call https://MY.INTRANET.COM:8081/openerp the title of the browser changes to OpenERP but the browser-windows stays white (with the following html-source-code):
Code:
<!DOCTYPE html>
<html style="height: 100%">
    <head>
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
        <meta http-equiv="content-type" content="text/html; charset=utf-8" />
        <title>OpenERP</title>
        <link rel="shortcut icon" href="/web/static/src/img/favicon.ico" type="image/x-icon"/>
        <link rel="stylesheet" href="/web/webclient/css">
        <script type="text/javascript" src="/web/webclient/js"></script>
        <script type="text/javascript">
            $(function() {
                var s = new openerp.init(["web"]);
                new s.web.WebClient().start();
            });
        </script>
    </head>
    <body class="openerp" id="oe"></body>
</html>


Could anybody tell what's wrong or how I can fix my setup to access my openerp-server via the remote proxy?

Any help is welcome, regards Mark

_________________
Openerp 6.1 on ubuntu 10.03 server


Top
 Profile  
 
 Post subject: Re: openerp 6.1 reverse proxy settings
PostPosted: Tue Mar 06, 2012 11:47 pm 
Offline

Joined: Mon Sep 05, 2011 9:31 am
Posts: 11
Location: Switzerland
Hi Mark

I've also this problem at this moment. Do you found any solution?

Best Regards
Raphael S.


Top
 Profile  
 
 Post subject: Re: openerp 6.1 reverse proxy settings
PostPosted: Wed Mar 07, 2012 4:07 pm 
Offline

Joined: Fri Jan 22, 2010 11:19 pm
Posts: 146
Hi Raphael,


I do not know very much about apache and proxy-configuration, like that I on my own will not be able to find the solution.

At the moment we are testing openerp (I think we will move to it within the next 3 month).
Like that I've time to wait until there will be a tutorial to get it working.

Regards Mark

_________________
Openerp 6.1 on ubuntu 10.03 server


Top
 Profile  
 
 Post subject: Re: openerp 6.1 reverse proxy settings
PostPosted: Sun Mar 11, 2012 1:38 am 
Offline

Joined: Sun Mar 11, 2012 1:17 am
Posts: 1
Location: Switzerland
I think the problem are the links to the javascripts (because most of the "html" is created by js client side and not on the serverside):

<script type="text/javascript" src="/web/webclient/js"></script>

use firebug or chrome dev tools to see if the browser is unable to find the js ressources.

sorry, i can't speak english:-(...


Top
 Profile  
 
 Post subject: Re: openerp 6.1 reverse proxy settings
PostPosted: Sun Mar 11, 2012 1:08 pm 
Offline

Joined: Wed Dec 09, 2009 11:58 am
Posts: 31
Location: Zuiddorpe
Same problem here,

The reverse proxy settings for 6.0 do not work for 6.1. I hope some info is posted soon...as I am looking forward in getting this to work.

Sorry but my technical knowledge is too limited to be of help in solving this.

Kind regards
Paul

_________________
[i][b]Server:[/b][/i] Ubuntu 10.04 LTS
[i][b]Clients:[/b][/i] Ubuntu 11.10
OpenERP (Evaluating V6.1)


Top
 Profile  
 
 Post subject: Re: openerp 6.1 reverse proxy settings
PostPosted: Wed Mar 14, 2012 11:12 am 
Offline

Joined: Fri Apr 21, 2006 7:28 pm
Posts: 1349
Location: Cambridge, UK
Paul_M wrote:
... The reverse proxy settings for 6.0 do not work for 6.1. I hope some info is posted soon...
The web server ('client') on OpenERP was completely rewritten between 6.0 and 6.1 so this is not surprising. There's another thread that describes a nonssl reverse proxy using apache, if that helps http://www.openerp.com/forum/post102867.html, and some info om a reverse proxy using nginx on the planet.

_________________
Regards, Geoff

Seath Solutions Ltd, Cambridge, UK


Top
 Profile  
 
 Post subject: Re: openerp 6.1 reverse proxy settings
PostPosted: Tue Sep 25, 2012 3:51 pm 
Offline

Joined: Thu Sep 20, 2012 2:57 pm
Posts: 4
Location: Malaysia
Sorry for interrupting abruptly.i found this thread while i was searching solution on how to edit the head title and also the text "Unsupport Community"

<head>
..
.....
<title>OpenERP</title> Unsupport Community

hope u could kindly share with me. Thanks in advance


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 7 posts ] 

All times are UTC + 2 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:

Protected by Anti-Spam ACP