This forum is now just an archive. Use the new Q&A website
It is currently Thu Apr 17, 2014 2:48 am

All times are UTC + 2 hours




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 
Author Message
 Post subject: Web 6.1behind HTTPS
PostPosted: Thu Mar 08, 2012 6:53 pm 
Offline

Joined: Mon Jul 11, 2011 6:14 pm
Posts: 32
Location: Lisbon, Portugal
I'm trying to configure 6.1's Web to be accessed through HTTPS.
I decided to use nginx for reverse proxy, but I'm having trouble to configure it to redirect even simple HTTP requests.

I have the OpenERP Web working on http://lapp:8081 or http://10.92.20.21:8081.
I want to configure nginx (v0.7.65) to respond at port 8080, and act as a proxy for the web server at port 8081.

Inside nginx.conf's http block I added:
Code:
    server {
        listen                  8080;
        server_name             lapp 10.92.20.21;
        location / { proxy_pass http://127.0.0.1:8081; }
    }


When I test this I get a "502 Bad Gateway" error page.
I have seen that 6.0 Web had some proxy configuration parameters; could this be what's missing?


Top
 Profile  
 
 Post subject: Re: Web 6.1behind HTTPS
PostPosted: Mon Mar 12, 2012 6:28 pm 
Offline

Joined: Mon Jul 11, 2011 6:14 pm
Posts: 32
Location: Lisbon, Portugal
The solution for the "502 Bad gateway" error start the server adding the "–xmlrpc-interface=127.0.0.1 –netrpc-interface=127.0.0.1" options.


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 

All times are UTC + 2 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:

Protected by Anti-Spam ACP